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Journyx 
Release: Pathway 
Version: 12.6.0  
 

Accessing New Features 

 
This guide includes descriptions of new features in Journyx and Journyx PX version 12.6.0 (“Pathway”) and 
is intended for existing Journyx customers who are upgrading to the Pathway release from Journyx 12.5.x.  
If you are upgrading from an earlier version, you will also need the guides for earlier versions.   
 
The Pathway release is only available for cloud customers right now.  If you have additional questions 
about a feature, please contact your account representative or email Journyx Support.  
 

 

User Management Screen Updates for Journyx  
 
The Pathway release includes more user interface updates to make more screens consistent with the 
style/technology of Journyx 12.  In this latest version the user management screens have been updated 
to be consistent with other updated management screens in v12, and they include improvements to the 
workflow for creating and managing users that dramatically improve the user experience and system 
access security. 
 
User management is located under Manage→User accounts→Manage users.  This screen now has the 
latest in search filter options, including remembering your last search.  All of the updated management 
screens include the option to customize the fields shown in the search results*.  The gear icon is available 
to all administrators in the upper right corner of the search results.  If you click on the gear icon, you can 
manage the fields in the results (add, remove, relabel, reorder).  As an administrator, you can also set 
default fields for other users of the management screen and/or give other users access to customize the 
fields on their own screens. 
 
*This should be a valuable feature for those of you who don’t use expense and/or custom entry in Journyx.  
Using the new field customization feature on the main user management screen, you can remove all of 
the unused information for expense and custom entry that is currently shown in the default user search 
results.  You can then add back user information that is more useful for your organization.  Don’t forget 
that you can also control the fields displayed in search results for projects, accruals, entry columns and 
approval queues as well. 
 
All of the updated management screens that previously had batch modification options on the main 
screen now have that functionality through the Compare and Modify process.  To make batch 
modifications (e.g., the same change for a list of items), select the users you want to modify and click on 
the Compare and Modify button.  On the next screen, you will see a button at the bottom of the screen 
labeled Batch Changes.  Click on this button, and you will see the different options (e.g., groups, roles) to 
make batch modifications to your selected users. 
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On the user create/modify screens you’ll notice that the fields have been reorganized based on the subject 
matter they cover.  Of particular note is the change to fields for managing passwords.  The password 
set/reset is now in its own popup screen where it will let you know if you’ve met your Journyx password 
security requirements as you create passwords.  For those of you who use single sign-on for Journyx 
access, this password field would only apply to accounts that will need to bypass SSO to access Journyx.  
On-screen messaging is now available to assist with proper password management based on your Journyx 
password settings. 
 
In order to support more robust password management for user, Journyx has added some new password 
security options under Settings→System settings→Security.  We encourage you to review the default 
values for the new settings and make sure they are a good fit for your password security processes.  The 
following is a list of new password security options with explanation: 
 

• When a new user is created, their default password for first sign-in is the same as their username. 
If this is off, there is no default password and the user can't sign in until a password is set. 
(Recommended: OFF) – As the setting text indicates, we recommend that you leave this setting 
turned off in production environments.  This setting is primarily for secure testing. 

• Required password strength (general complexity) – This is a new setting that was previously used 
to measure the strength of user passwords as they entered them, but it could not be enforced.  
Now you can use this option to enforce password complexity and block new passwords that don’t 
meet your security threshold.  The default threshold for this setting starts at Medium.  We 
encourage administrators/system testers to try out various password changes to determine what 
level of security is right for your organization.   

 
NOTE:  The new password settings will be set to default values based on Journyx minimum security 
recommendations and best practices.  If you notice a change to your password process after creating a 
new user in v12.6.0, please contact Journyx Support for assistance with your password settings and 
process. 
 

Resource Requisition Management Screen & Workflow Updates for Journyx PX 
 
The Pathway release includes even more user interface updates to make more screens consistent with 
the style/technology of Journyx 12.  In this latest version the resource requisition screens in Journyx PX  
have been updated to be consistent with other updated management screens in v12.  The updates also 
include improvements to the workflow for splitting requisitions amongst several managers and control 
over notifications for a more robust process. 
 
Resource requisition management is located under Manage→Resources→Manage requisitions.  This 
screen now has the latest in search filter options, including remembering your last search.  All of the 
updated management screens include the option to customize the fields shown in the search results.  The 
gear icon is available to all administrators in the upper right corner of the search results.  If you click on 
the gear icon, you can manage the fields in the results (add, remove, relabel, reorder).  As an 
administrator, you can also set default fields for other users of the management screen and/or give other 
users access to customize the fields on their own screens. 
 
Prior to the Pathway release, you could only create a requisition for a single resource manager.  Now you  
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can split a single requisition amongst as many resource managers as you choose.  When you select more 
than one resource manager and click the Save button, a dialog box will pop up that allows you to split the 
scheduled hours/work associated with the requisition across the list of selected managers in any amounts 
you like.  Visual cues ensure that you assign the same total hours as the original requisition. 
 
In the Pathway release you also have more control over notifications and content of the notifications 
triggered by actions take on requisitions.  You can turn on notifications and customize the notification 
content by going to Settings→System settings→Resource requisitions. 
 

Request Leave on Behalf of Others & Leave Duration Limits 
 
If you are assigned to a role where you can manage leave for others (e.g. view/approve leave requests), 
you can now go to Analyze→Leave calendar→All leave requests to request leave on behalf of those 
you manage provided your Journyx administrator has turned on this option.   
 
Administrators can turn on the option to request leave for others by going to Settings→System 
settings→Leave requests.  The setting “Allow managers to create leave requests for employees” adds a 
section to the foot of the leave request management screen for those who have access to approve and 
manage leave for others.  After selecting a user on this screen, managers will then see the leave request 
create options that the selected user would also see, and they can create the request on behalf of the 
user. 
 
In addition to the option to create requests for others, there are two new options for managing the 
duration of leave requests created by users and managers.   Under Settings→System settings→Leave 
requests you can set the maximum number of days to warn users about a long leave request by turning 
on this setting:  “Warn users if they try to create a leave request longer than a certain number of days”.  
Just below this setting you can also set a maximum number of days before blocking creation of a request 
by turning on this setting:  “Prevent users from creating a leave request longer than a certain number of 
days”. 
 

Payroll Rules Engine (PRE) Incorporated in Journyx Core Product 
 
If you are an Administrator of the Journyx system, or you are assigned to a role with the new Payroll 
Export- Admin ability, you can now go to Analyze→Exports→Payroll data to set up your payroll rules 
for processing and export.    The “PRE” was previously a separate add-on delivered by Journyx 
Professional Services.  In v12.6.0, it is now incorporated into the core Journyx product.  As a result, it no 
longer appears under the Tools menu where other Professional Services add-ons are typically found. 
 
While a lot of information was cleaned up and standardized, the features and options are mostly 
unchanged.  Error handling was improved, and there is a new option to ignore pay groups that aren’t set 
up/configured correctly so that you can run the payroll export for the groups that are ready.  There is 
also another new role ability, Payroll Export – User, that allows someone with a role that includes the 
ability to run the payroll export.  However, it will not allow them to change the payroll rule 
configuration. 
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New Full Sheet View Option in Manager Sheet/Project Approvals 
 
If you are a sheet/period or project approver, you can now go to Manage→Approvals to see a third 
options for viewing sheets.  Prior to v12.6.0, your two sheet view options were “Comments” (a project 
summary view) and “Days” (time totals shown by project and day).  Now approvers can choose a third 
view, Full Sheet, as their default view* for approvals.  This new view loads the detailed grid view 
(including in/out times, notes, attachments, PRE summary, other custom information) in the approver 
sheet view window.  While the link to the Full Sheet is still available, this new view will replace the need 
to click through to the full sheet in most cases.  
 
You cannot set the default view for your approvers.  Journyx recommends that you alert your 
organization’s approvers that this new sheet view option is available. 

 

Miscellaneous Features 
 

• Ability to search using custom text fields:  Prior to v12.6.0, the only custom text fields available 
to include in management screen searches were fields set up as selection list fields.  Basic/static 
text fields were not an option for management searches.  With the updates to the user 
management screen, static text fields are now available for inclusion on management screens 
under Settings→Manage fields and roles→Manage search filters.    

• Layout fix for approval system reports for multiple levels of approval:  Prior to v12.6.0, the 
approval system report available under Analyze→Exports→System reports did not list multiple 
approvers in a plan on distinct lines.  Now each approver has a dedicated line for the approval 
plan information based on the level assigned. 

• New chart options to control how much data is shown:  Prior to v12.6.0, all charts in Journyx 
were set to show a certain threshold of data points before the remaining data was summarized 
into an Other category.  Now you can decide how much data you want to show in a single chart, 
and you can also view large data sets in a paginated format for more control over how you view 
your visual data. 

• Load time/search time improvements for project and other management screens:  The 
Pathway release includes continued load time and performance improvements for handling 
large data sets on the new, redesigned management screens.  

• New calendar availability graphs on PX resource availability:  In 12.6.0, the old style calendar 
availability graphs on Manage→Resources→Resource availability have been replaced with the 
new, easier-to-read calendar graphs that are also available on the assignment managements 
screens.    

• Actual hours field added back to PX assignment management:  In 12.6.0, the Actual Hours field 
for unassigned and existing assignments was added to the new assignment management 
screens.   

 
A number of bugs were also fixed in the Pathway release, and you can view the complete change list for 
the Pathway release here.  If you would like additional training on the Pathway release or would like 
your site assessed for optimization, please contact your account manager to discuss options we have 
available. 
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